View Full Version : Setting up the Spanish Yoigo card for GPRS internet connection

04-10-07, 20:35
I've just bought a Spanish Yoigo sim card to allow me to connect to the internet via a Bluetooth phone. The deal is 1.5 Euros a day approx for unlimited connection. What few instructions there are, are in Spanish, and only relate to getting the phone connected. For information:-

To get the correct settings into your phone, send an SMS with the word 'TODO' to 500. With some phones that's all you need to do for the settings to be texted back and made available for automatic install. With other phones, you get a message back in Spanish that tells you to send another text with the model of the phone to 500. In my case, a Nokia 6310i, I sent '6310i' to 500 and back came a text recognising that it was the Nokia with all the settings in place - all I had to do was press 'Save' and the job was done.

Now, that's as far as I have gone. When I try to connect to the internet at the phone level, it says that it is connecting, then says that connection was lost with no connection whatsoever. It could be a local issue here - not everywhere has a working GPRS service.

What I don't know, maybe someone can help, is how to set up the laptop to communicate via Bluetooth. Presumably I have to go to Connections and start a new connection but I have no idea what settings to put in place. Maybe someone can tell me?

04-10-07, 20:44

Cant help with the phone connection... When necessary I hardwire my PDA thing to the PC via USB and connect that way... but I'd guess it's different for different phones.

You probably know that the APN is internet and, whilst it might not need a user name and password, my software often does so I used user and 1234 respectively. Is there somewhere in your phone where these 3 things need to go, (which might be what Yoigo are trying to send you).

As I think you know, I use an Option Globetrotter datacard in the PCMCIA slot on the laptop, and only need the above info to connect.

Not sure if this helps

Richard..... In Malta!!

Steve Clayton
04-10-07, 20:53
Assume the laptop is bluetooth enabled.

Enable bluetooth on the 6310i and then use the phone b'tooth software to pair up with the laptop. (From Bluetooth showing on the menu on the phone use the down arrow for the pairing options). The 6310i also has GPRS modem settings under top level Settings which should be OK. Then try again and see what happens

04-10-07, 21:18
Richard, I was hoping you'd come to the rescue. Thanks /forums/images/graemlins/smile.gif Congratulations for getting to Malta - good passage and satisfactory berthing?

I seem to have set the phone up OK albeit that I am not actually connecting, it looks as though it would if it could but probably can't for local reasons. I don't need it here as I have WiFi and I bought the card so that I can use it while travelling about and next year, when cruising.

My phone is a Bluetooth phone and I used to use it with Orange GPRS and Bluetooth with the same laptop in the UK so I know that the hardware combination works...it is just a matter of getting the settings right in Windows XP, I think. Orange talked me through it on the phone in the UK but my Spanish isn't yet good enough to handle that.

04-10-07, 22:03
Yes, the laptop is Bluetooth enabled (internal Dell card) and the phone is in regular Bluetooth use with my Tom Tom. I haven't used the laptop with Bluetooth for ages. I used to get a little Bluetooth logo down on the bottom right toolbar. Right now, I have the network icon (two pc screens) with an X over it, and a mouseover message of Bluetooth Network 'A Network cable is unplugged'. Yet I have checked in Device Manager that all is connected and is said to be working. In Network Connections it is said to be enabled but "Network cable unplugged". I have a feeling at the back of my mind that I went through this four years ago but I can't remember what I need to do to re-enable the internal Bluetooth card.

Steve Clayton
05-10-07, 04:30
When you try and pair the phone and the laptop does the phone find the laptop as a device? If it can't be found then someone else will have assist in the troubleshooting of the laptop - what about reinstalling the bluetooth driver?

05-10-07, 07:57
These setting may help

* Data bearer: GPRS
* Access point name: Internet
* User Name: None
* Prompt Password: No
* Password: Leave blank (shows as ****)
* Authentication: Normal
* Gateway IP address:
* Homepage: http://movil.yoigo.es
* Connection security: Off
* Session Mode: Permanent

Then under Advanced Settings (hit the menu softkey from the access point setup screen to find these):

* Phone IP address: Dynamic
* Primary name server:
* Second. name server:
* Server address:
* Port Number: 8080

05-10-07, 15:15
Thanks Steve, bendyone,....

I found that installing XP SP2 on my laptop had over-written and corrupted the original Dell Bluetooth software and driver - it seems that this is a common problem as SP2 provides native windows support for the first time. Microsoft give instructions how to remove their Bluetooth stuff - incredible, the mind boggles, why do they behave like this??

Anyway, after much research and messing about I now have Bluetooth connection possible between the phone and the laptop. bendyone, the details that you kindly posted have already been entered automatically by the routine I posted in the OP - actually there are minor differences but I suspect that the Yoigo automatic settings are the correct ones.

Now I need to know how to set up a connection in XP. I have tried using Network Connections as a dial up modem but that only accesses the regular modem. I also have a Bliuetooth My Bluetooth Places connection interface but that is very strange...when I try to set up a new connection it keeps opening up the System Properties interface which makes no sense to me.

Does anyone have any ideas?

Many thanks.

05-10-07, 20:30
-Your bluetooth software should set up a DUN connection which talks to the phone via a com port, you may need to install the phone's modem script on the laptop and tell the bluetooth DUN which modem to connect to, also you will need the "number" for it to talk to ( vodafone is *99#) depends on your phone.

05-10-07, 20:51
just go to Nokia support web site and all of your questions will be answered.

settings from here
settings (http://europe.nokia.com/A4144889)

Modem setup
modem setup (http://europe.nokia.com/appmanager/UnitedStatesEnglishEUROPE_NOKIA_COM_3/Get_support;JSESSIONID_NCOM=QrDbHGvbH8L5PXThQTtDRy M1XpnX3wblvsTQQT8VCNQvJ0lfJhKv!711266469?_nfpb=tru e&_windowLabel=T2034178831149510625312&_pageLabel= P157533&wsrp-urlType=blockingAction&wsrp-url=&wsrp-requiresRewrite=&wsrp-navigationalState=&wsrp-interactionState=_action%3D%2Fpageflows%2FEMEASupp ortTool%2Fbegin&wsrp-mode=&wsrp-windowState=)

PC suite
PC suite (http://europe.nokia.com/A4143074)

06-10-07, 17:10
Well, thanks to you guys I think that I am nearly there albeit after two days work /forums/images/graemlins/frown.gif

It seems that the Dell Truemobile Bluetooth 300 card is not compatible with XP SP2 - on the Dell Forum a question about this has clocked up a thousand reads and there is not answer. The internal card is apparently connected to the USB bus, internally and I shall have to remove it by taking it apart, in due course, but for now I have bought a Belkin dongle-type. Mind you, that has not installed cleanly, it is a real pig's ear of an installation that inspires one with no confidence at all.

However, I am now getting full pairing and from a Bluetooth DUN icon I can get the phone to start to access the network. First, let me say, in 'Navegador' mode (wap browsing, I think) it works fine, so I have money on the card and can connect via my phone without Bluetooth. I have to set the phone to Internet to work with the laptop, of course.

When I try to connect the phone says:-

Connecting.......Connect with Laptop?

I then 'Accept'

Phone - "Connected to Laptop" for 2 seconds then "Creating GPRS connection" then "Subscribe to GPRS first" at which the connection drops out and I get an error messge on the Laptop "Error 734: The PPP Link control protocol was terminated"

I thought that I must be subscribed to GPRS given that I can browe happily on the phone (not in Internet mode) and see the news, etc., with G on the display signifying GPRS.

So near, but yet so far?

Many thanks, chaps, for some 'on the button' help so far.

06-10-07, 23:27
I've found the problem so for the sake of other searching from here and elsewhere on the internet, this is what I found....

In the Nokia 6310i there are TWO places where the GPRS modem needs to be specified. Under "Settings" and under "Services" All of the internet and data stuff is carried out under Services and the modem was correctly specified in there but on the off-chance I re-typed the designated name under Settings > GPRS modem settings > Edit acess point and I changed the name for Access Point 5 (an arbitrary one) to 'internet'. Then the thing worked perfectly.

Thanks to you all for your help - much appreciated and very necessary! /forums/images/graemlins/smile.gif

12-10-07, 13:50
Also for the sake of others searching...

I had a similar problem with a Dell Vostro 1500. It turns out that the laptop bluetooth module is compatible with XP SP2 but it needs a driver download from here (http://support.dell.com/support/downloads/download.aspx?c=us&cs=555&l=en&s=biz&releaseid=R16 1378&SystemID=VOS_N_1500&servicetag=&os=WW1&osl=en &deviceid=12084&devlib=0&typecnt=0&vercnt=1&cat id=-1&impid=-1&formatcnt=1&libid=5&fileid=216131) before XP will recognise it /forums/images/graemlins/ooo.gif

12-10-07, 15:59
Glad to hear you got it working in the end. How's your connection? I ask because I use yoigo, sony ericsson K800i connected with lead straight to laptop and the connection keeps dropping out, very annoying, it will be fine for a little while then seem to lock up, i'll have to disconnect and reconnect to get back online. Anyone else have this problem with yoigo? Wierdly, if I get itunes to download a podcast or something most of the time it will happily download for hours. E1.30 per day is good though.



12-10-07, 16:09
Well, I have only really tested it to see that we have service as I have pretty good WiFi in the marina. I found it painfully slow for things like downloading the daily newspaper on PressReader - Lord knows how long that would take - but I was able to browse, access YBW /forums/images/graemlins/smile.gif and get into my bank. I really want it more when we are travelling about in the winter, and when we leave the marina again in April/May so will try to remember to report back then.

If your connection is dropping out maybe you need to check the time-outs? Or check that your signal is consistently good? Or, I wonder, whether you drop out on inactivity? I find that Skype often locks up a router that I use as a WiFi relay - after a few mins. of Skype call it needs to be powered down/up. I have found the same with a router I have in the UK from a different mfr. So maybe don't leave Skye running? If you are dropping out due to non-use, can you leave a small monitoring program in the background - e.g. set Outlook to every 30 seconds?

04-05-08, 07:39
Update: I only use the Yoigo when the local service in the marina packs up or when we travel around Spain. Since October, we have used it in Gibraltar, Baza and Ronda as well as Almerimar. The connection is very robust - stays connected for a hour or more, sometimes four. However, the speed is unbelievably slow. My NetMeter shows a download speed of around 3kB/s most of the time which makes email download using Outlook difficult. I find myself using Airmail instead. Some pages high in Java time out before loading (e.g. www.bloomberg.com (http://www.bloomberg.com)) Skype connects and gives text but voice is unusable.

So, after chatting to Richard, I have ordered the open Vodafone PCMCIA card and external antenna. Will report back.

I need to find out which PAYG sim card I can use in this device for France and Italy.