Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Firefly211 is offline Registered User
    Location : Living aboard in Estepona.
    Join Date
    Oct 2010
    Posts
    79

    Default Fusion Stereo Radio Reception = Sub Standard Crystal set!!!

    Right, am a bit p****d off! Last summer I bought a very nice Fusion 600 stereo and never got round to fitting it till last weekend. I butchered the nav station panel to take it. Had to move the Glomex and Eberspacher as the Fusion needs a bit more space around it for the drop down panel. Nav panel looks like a culender. Grrr

    iPod works great with excellent sound and love the zones function... but the radio is God awful...and I mean truly awful. The previous VDO Dayton unit was fine and the Fusion? Well it's cr**p. I have tried three other antennas with no improvement and as I have had it so long I don't think I can rightly take it back to supplier?

    Anyone else had any problem with Fusion?

    Sorry to rant - but it took me hours and I've done more harm than good!

  2. #2
    Join Date
    Mar 2009
    Posts
    91

    Default

    I fitted the same model in the winter.
    2 zones 4 speakers..

    It seems to work just fine on Ipod, Radio and aux inputs.

    I just connected it to the same ariel as the old Pioneer car radio was using.

    Perhaps you have a dud set? can you return it to the supplier?

  3. #3
    Firefly211 is offline Registered User
    Location : Living aboard in Estepona.
    Join Date
    Oct 2010
    Posts
    79

    Default

    I might very well have a dud. But like I said I bought it from force4 last summer when I was on my hols and finally fitted it last week. I will give them a call and see what they can do re a replacement.

    Glad yours is ok though Like I said the iPod side is fantastic!

  4. #4
    Join Date
    Oct 2001
    Posts
    6,925

    Default

    So you've not had it a year. Seeing as Fusion seems to be a "premium" brand I'd say that it'll have a min of a years warranty on it. I'd be back there with it. Force 4 seem a fairly pro bunch. I can't see them not giving you an exchange, especially as you've had to cut the boat about to fit it. Give it a go, what have you got to loose?

  5. #5
    Join Date
    Jan 2006
    Posts
    2,698

    Default

    Quote Originally Posted by BarryH View Post
    So you've not had it a year. Seeing as Fusion seems to be a "premium" brand I'd say that it'll have a min of a years warranty on it. I'd be back there with it. Force 4 seem a fairly pro bunch. I can't see them not giving you an exchange, especially as you've had to cut the boat about to fit it. Give it a go, what have you got to loose?
    Doesn't need a warranty. It is not fit for purpose under the Sale of Goods Act.

  6. #6
    prv is offline Registered User
    Location : Southampton
    Join Date
    Nov 2009
    Posts
    22,373

    Default

    Quote Originally Posted by st599 View Post
    Doesn't need a warranty. It is not fit for purpose under the Sale of Goods Act.
    +1, and although SoGA needs you to report "not fit for purpose" within a reasonable time, buying something but not fitting it for a while is recognised as a valid reason for delay.

    Pete

  7. #7
    Join Date
    May 2003
    Posts
    404

    Default

    Quote Originally Posted by prv View Post
    +1, and although SoGA needs you to report "not fit for purpose" within a reasonable time, buying something but not fitting it for a while is recognised as a valid reason for delay.

    Pete
    I believe "Reasonable time" is five years in England, six in Scotland.

  8. #8
    Join Date
    Oct 2005
    Posts
    3,843

    Default

    I have the 200 model, which picks up the radio fine with a small aerial.
    Living the dream!
    www.yacht-tinkerbell.co.uk

  9. #9
    Join Date
    Jun 2009
    Posts
    8,046

    Default

    We have a Simrad Sonic Hub which is a rebadged Fusion and the reception is fine - antenna was installed by Jeanneau with the boat and seems to be an active dipole installed under the shelf behind the bench.

  10. #10
    Firefly211 is offline Registered User
    Location : Living aboard in Estepona.
    Join Date
    Oct 2010
    Posts
    79

    Default Urm, sorry Fusion

    Quote Originally Posted by Firefly211 View Post
    Right, am a bit p****d off! Last summer I bought a very nice Fusion 600 stereo and never got round to fitting it till last weekend. I butchered the nav station panel to take it. Had to move the Glomex and Eberspacher as the Fusion needs a bit more space around it for the drop down panel. Nav panel looks like a culender. Grrr

    iPod works great with excellent sound and love the zones function... but the radio is God awful...and I mean truly awful. The previous VDO Dayton unit was fine and the Fusion? Well it's cr**p. I have tried three other antennas with no improvement and as I have had it so long I don't think I can rightly take it back to supplier?

    Anyone else had any problem with Fusion?

    Sorry to rant - but it took me hours and I've done more harm than good!
    I hereby offer many and complete apologies to Fusion. Clearly the instructions said to set the regional settings to Europe and not the default USA. Once I had a chat with em about my problem it was resolved in about 20 secs. Now have great reception. If only stupid people (like me) would read the bl**dy instructions!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •