Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2008
    Location
    Isle of Man
    Posts
    1,325

    Default Sunseeker 240v question

    Got my new boat home and just working through the systems.

    Connected up shore power (had to put a new end on one end as the socket was too big for our towers)

    All seemed fine and the battery charger kicked in as the amps jumped. Iím sure only a small amber light came on at the main panel as below (broker shot from ages ago

    095E5617-661B-4FFD-8483-0ED1AEDA68FB.jpeg

    Did some other stuff (started an engine too) and on going back down.....no more amps being drawn and batt charger is off. Itís a victron blue charge. Yet to check the fuse in it but I bet itís blown.

    On the main panel the red led is lit too. I canít be sure it wasnít before but do you think Iíve reversed the polarity? I thought I wired it exactly the same as the old shorepower connector. Any idea what Sunseeker Amber, Red, Green lights mean on the panel.

  2. #2
    Join Date
    Aug 2012
    Posts
    10

    Default Re: Sunseeker 240v question

    Just an observation. If you have changed from a large marina socket to a small socket you have gone from 32amps to 16amp supply. This may not be a problem, more likely to be a problem going the other way. I defer to Greater knowledge on this matter.

  3. #3
    Join Date
    Jun 2017
    Posts
    35

    Default Re: Sunseeker 240v question

    To find out if your 240VAC is healthy, just buy one of these.
    https://www.pattesters.co.uk/martind...xoC_1MQAvD_BwE

    Will tell you at least that the wiring is correctly connected.

    Many boat chargers take a pause when charging so that they do not cook the batteries. So quite likely nothing wrong with it at all. Looks to me from the pic that you have a perfectly healthy battery.

    For what it is worth, and I really am not sure I am right about this, but I never start the engine with the battery charger connected - just in case it pulls too much from the charger.

    Congratulations on your new boat - just go drive it

  4. #4
    Join Date
    Apr 2008
    Location
    Isle of Man
    Posts
    1,325

    Default Re: Sunseeker 240v question

    Thanks fo the comments. The panel doesn’t look like that today. Amber and red light on, no amps getting drawn.

    I’ve got a friend at Sunseeker who will ask someone in the know this week. The charger has a reverse polarity fuse which has not blown. Need to check it’s getting power before worrying it’s fubar.

    Could be the reset fuse at the panel. Getting to know the boat anyway

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest YBW News

Find Boats For Sale

to
to