Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2007
    Posts
    47

    Default Alternator repair

    Hi All.
    I have had my Volvo AD41 Alternator repaired, its charging ok now but the volt mtr now goes to minus 10 when I run the engine, everything else is ok Taco Ing light all work ok, I checked the charge from the Alternator its charging around 13,5v I have double checked the wires, its not possible to get them on wrong as the connections have different size holes, the Alternator is a Paris Rhone.
    Any help would be great

  2. #2
    Join Date
    Apr 2007
    Location
    Westwick - Essex
    Posts
    90

    Default Re: Alternator repair

    Hi - just to bump this up as hopefully someone with more knowledge than me can assist!
    Apart from the usual tracing dodgy earth problems it is certainly a strange fault.
    Just to throw in a curved ball though... is this a twin engine set-up? Do you have the emergency battery starting circuit where a push button on the dash changes the batteries over?
    I remember when I was upgrading the batteries, switches, cables and solenoids etc; I was getting some very odd readings as the previous owner wired one of the relays to the wrong side of the battery on / off switch.

  3. #3
    Join Date
    Mar 2007
    Posts
    47

    Default Re: Alternator repair

    Hi All
    I have checked with the repair shop, and all the did was a clean and function test, I have been checking things this morning, so far the Alternator is charging ok, it charges the Domestic batteries, on the wiring side of the Alternator it seams that one of the wires well its two together on one crimp connector, if I leave this disconnected all is ok Oil, Water gages ok rev counter Ing light ok, charging but the volt mtr stays at 12v.

  4. #4
    Join Date
    Jan 2009
    Location
    Stratford on Avon
    Posts
    10,827

    Default Re: Alternator repair

    I had the control unit pop on Rafiki a couple of years ago. I stupidly started the engine with shorepower connected. A good auto repaired fixed it. May be a total red herring to you, so apologies if so.

  5. #5
    Join Date
    Mar 2004
    Posts
    5,468

    Default Re: Alternator repair

    Quote Originally Posted by rafiki_ View Post
    I had the control unit pop on Rafiki a couple of years ago. I stupidly started the engine with shorepower connected. A good auto repaired fixed it. May be a total red herring to you, so apologies if so.
    why would that cause an prob ?
    assuming the shore power fed the wired in mains battery charger ?

  6. #6
    Join Date
    Jan 2009
    Location
    Stratford on Avon
    Posts
    10,827

    Default Re: Alternator repair

    The shorepower caused a spike with fried the controller. Shouldn’t happen, but can do on shorepower, so good practice is to disconnect before starting up.

  7. #7
    Join Date
    Oct 2013
    Posts
    136

    Default Re: Alternator repair

    A shot in the dark, but if the voltmeter reads OK With the engine not running and goes minus when it is running, possible you have connected a wire that should go on the B+ to the Indicator connection. Some alternators have a diode trio that makes the alt light light. Basically the light connects to positive, the other side to the diode trio, when the alternator isn’t running it forms the negative so the light lights, when the alternator runs it produces positive so the light with 2 positives goes out. Check you connections again

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest YBW News

Find Boats For Sale

to
to