Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2017
    Posts
    27

    Default Suzuki 20Hp 4 Stroke

    Quick question but has anybody out there in winter forum land got a Suzuki 20Hp 4 stroke, I got mine as part of the Brig package and quite frankly its awful. It sounds and vibrates like a two stroke and even gave us eyeball resonance at ticker. any thoughts would be great , oh and it is less than 6 months old .

  2. #2
    Join Date
    Jun 2010
    Location
    Andover Boat:Gosport
    Posts
    646

    Default Re: Suzuki 20Hp 4 Stroke

    Mines so quite you can hardly hear/feel it running at low revs, I'd take it back to where you bought it as I think you must have something broken. Or try Marine Matters in Warsash if local to you they are a dealer for both your toys

  3. #3
    Join Date
    Oct 2017
    Posts
    27

    Default Re: Suzuki 20Hp 4 Stroke

    Thats where it came from ! its been back twice and I'm still not happy I have to say

  4. #4
    Join Date
    Oct 2013
    Location
    Home Basingstoke Boat Shamrock Quay, Southampton
    Posts
    39

    Default Re: Suzuki 20Hp 4 Stroke

    I bought mine this year. At tickover it's extremely quiet and no vibration

  5. #5
    Join Date
    Jun 2004
    Location
    Anglesey Wales
    Posts
    10,964

    Default Re: Suzuki 20Hp 4 Stroke

    Quote Originally Posted by ExplorerTarga52 View Post
    Thats where it came from ! its been back twice and I'm still not happy I have to say
    It should purr like a kitten at all revs
    'Where it came from' What do they say??

  6. #6
    Join Date
    Oct 2017
    Posts
    27

    Default Re: Suzuki 20Hp 4 Stroke

    sorry for the delay but I was in hospital all over xmas deep joy. They basically said it was fine and that the vibration was due to the setting of the clamps on the transom . i.e. no difference at all.
    Thanks to all for confirming my concerns

  7. #7
    Join Date
    May 2001
    Posts
    15,006

    Default Re: Suzuki 20Hp 4 Stroke

    Quote Originally Posted by ExplorerTarga52 View Post
    sorry for the delay but I was in hospital all over xmas deep joy. They basically said it was fine and that the vibration was due to the setting of the clamps on the transom . i.e. no difference at all.
    Thanks to all for confirming my concerns
    Sounds like bullsh1t.

    Hope you’re feeling better.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest YBW News

Find Boats For Sale

to
to