Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2004
    Location
    UK Spain
    Posts
    392

    Default Salt water pump "hunting"

    I have a salt water pump to wash down decks whilst at sea.
    The last time I tried to use it there was an initial steady flow from the hose but then the pump seemed to switch on and off and as a result the water flow was flowing in short bursts.

    Any clues as how to resolve the problem gratefully received?

  2. #2
    Join Date
    Oct 2003
    Location
    west yorkshire
    Posts
    4,052

    Default Re: Salt water pump "hunting"

    could be the accumulator (if fitted) diaphragm has failed or just a dodgy pressure switch (little micro switch)
    or it could be the impeller has gone in the pump. what kind of pump is it?
    Last edited by kashurst; 04-10-19 at 16:54.

  3. #3
    Join Date
    Dec 2005
    Location
    Live London
    Posts
    3,831

    Default Re: Salt water pump "hunting"

    All of the above plus the possibility of a collapsing hose.

  4. #4
    Join Date
    Feb 2004
    Location
    UK Spain
    Posts
    392

    Default Re: Salt water pump "hunting"

    Good question! The boat is in Spain and I am now in the UK. Problem started the day before I was due back to UK. Did not have time to inspect before returning. Just looking for pointers before I go back out.

    Cheers

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest YBW News

Find Boats For Sale

to
to