Page 1 of 3 123 LastLast
Results 1 to 10 of 23
  1. #1
    Join Date
    Jul 2012
    Location
    Cardiff
    Posts
    217

    Default Shore power not charging batterys

    Hi all my consumer unit is not charging my 3 batterys has anybody got recommendations or links for a new one if I cant find out why its not working,
    My 240 plugs work, also my water heater works,
    But charging side don't,
    It's for an Antares 9
    they charge ok from the engine,

  2. #2
    Join Date
    Apr 2008
    Location
    Isle of Man
    Posts
    2,164

    Default Re: Shore power not charging batterys

    Bit extreme needing a new panel!

    fuse in the charging unit gone? Any lights on the unit? Pop out fuse or trip in consumer unit blown/faulty...etc

  3. #3
    Join Date
    Mar 2015
    Location
    Isle of Eigg
    Posts
    7,708

    Default Re: Shore power not charging batterys

    Charging from the engine will be low voltage from the alternator (unless you are really weird and run an inverter to run the battery charger...)
    So, you have a dead 240V battery charger or its 240V supply or its cables to the battery system.
    Start at the charger, do its lights light up?
    If so, measure its output (at the charger) both when it has power and when it does not.
    If you see 0V there, the wiring to the batteries is faulty.
    If you only see the same voltage there whether it is powered or not then its output fuse is broke or it is broke.

  4. #4
    Join Date
    Jul 2012
    Location
    Cardiff
    Posts
    217

    Default Re: Shore power not charging batterys

    Thanks guys I will have a look for an internal fuse on the weekend I flicked the trip switches no change,
    Its an alpha one unit anybody know this unit,

  5. #5
    Join Date
    Mar 2006
    Location
    Manchester
    Posts
    17,392

    Default Re: Shore power not charging batterys

    Quote Originally Posted by Lon nan Gruagach View Post
    Charging from the engine will be low voltage from the alternator (unless you are really weird and run an inverter to run the battery charger...)
    Not so weird these days, it would seem.

    I’m considering a bank of LiFePo4 battery cells and there are some issues with charging directly from an alternator. Mainly related to the fact that Alternators reach an absorption voltage, but don’t go into float. The absorption voltage being too high for lithium’s.

    As a consequence, my mind wandered and came up with the idea of running the charger from the inverter when the engine is running.

    Go figure!!!
    Narrowboating From Stretford!!

  6. #6
    Join Date
    May 2002
    Location
    Oxfordshire
    Posts
    136

    Default Re: Shore power not charging batterys

    Quote Originally Posted by Richard10002 View Post
    Not so weird these days, it would seem.

    I’m considering a bank of LiFePo4 battery cells and there are some issues with charging directly from an alternator. Mainly related to the fact that Alternators reach an absorption voltage, but don’t go into float. The absorption voltage being too high for lithium’s.

    As a consequence, my mind wandered and came up with the idea of running the charger from the inverter when the engine is running.

    Go figure!!!
    You might be better off looking at the Mastervolt Alpha Pro alternator and charge regulator. That will give you a 3 step charge when the engine is running.

  7. #7
    Join Date
    Mar 2015
    Location
    Isle of Eigg
    Posts
    7,708

    Default Re: Shore power not charging batterys

    Quote Originally Posted by Richard10002 View Post
    Not so weird these days, it would seem.

    I’m considering a bank of LiFePo4 battery cells and there are some issues with charging directly from an alternator. Mainly related to the fact that Alternators reach an absorption voltage, but don’t go into float. The absorption voltage being too high for lithium’s.

    As a consequence, my mind wandered and came up with the idea of running the charger from the inverter when the engine is running.

    Go figure!!!
    Yeah,if you cant get a low voltage powered LiFePo4 battery charger.
    I would never dream of using LI(anything) without full charge,discharge dedicated circuit including temperature sensing. When they go, they really go! Not to mention that excessive discharge will dodo them in the blink of an eye.

  8. #8
    Join Date
    Mar 2006
    Location
    Manchester
    Posts
    17,392

    Default Re: Shore power not charging batterys

    Quote Originally Posted by Lon nan Gruagach View Post
    Yeah,if you cant get a low voltage powered LiFePo4 battery charger.
    I would never dream of using LI(anything) without full charge,discharge dedicated circuit including temperature sensing. When they go, they really go! Not to mention that excessive discharge will dodo them in the blink of an eye.
    Yes! It’s a big topic, so not for this thread. I was merely struck by the comment that charging batteries via the inverter is weird, (and it is!), but no longer as weird as it has been to date
    Narrowboating From Stretford!!

  9. #9
    Join Date
    Jul 2012
    Location
    Cardiff
    Posts
    217

    Default Re: Shore power not charging batterys

    Guys I think you have hijacked this thread with your own issues I'm the one looking for help and info

  10. #10
    Join Date
    Mar 2006
    Location
    Manchester
    Posts
    17,392

    Default Re: Shore power not charging batterys

    Agreed! Sorry! I did say in #8 that it's a big topic and not for this thread.

    I merely saw a statement which would probably attract no contradiction in previous, or even recent, times, but which is probably no longer the case.
    Narrowboating From Stretford!!

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Latest YBW News

Find Boats For Sale

to
to